import re
regex = re.compile(r"(.+\B)\s+(\1(\s+)?)+", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Hey salut a tous les amis ! Hey salut a tous les amis ! #\n"
"salut a tous les amis ! Hey salut a tous les amis !\n"
"salut a tous les amis ! Hey salut a tous les amis ! #\n\n"
"Comment allez vous ?\n"
"Bien et toi ?\n"
"Bien et toi ? #\n\n\n"
"Comment allez vous ? #\n\n"
"Comment allez vous ? #\n\n"
"a\n\n"
"Salut comment vas ? Salut comment vas ? #\n"
"a\n\n"
"Salut ça va? salut ça va? #")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")