#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=<FilesMatch "test">)((.|\n)*?)(?=<\/FilesMatch>)"
Local $sString = "<FilesMatch "test">" & @CRLF & _
"Order deny,allow" & @CRLF & _
"deny from all" & @CRLF & _
"allow from 111.111.111.111" & @CRLF & _
"</FilesMatch>" & @CRLF & _
"" & @CRLF & _
"<FilesMatch "nottest">" & @CRLF & _
"Order deny,allow" & @CRLF & _
"deny from all" & @CRLF & _
"allow from 222.222.222.222" & @CRLF & _
"</FilesMatch>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")