import Foundation
let pattern = #"(?<=<FilesMatch "test">)((.|\n)*?)(?=<\/FilesMatch>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<FilesMatch "test">
Order deny,allow
deny from all
allow from 111.111.111.111
</FilesMatch>
<FilesMatch "nottest">
Order deny,allow
deny from all
allow from 222.222.222.222
</FilesMatch>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}