#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=([^\?\&\=]+=)([^\&\=]+))(\&\1)"
Local $sString = "?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits"
Local $sSubst = "~"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)