import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=([^\\?\\&\\=]+=)([^\\&\\=]+))(\\&\\1)";
final String string = "?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits";
final String subst = "~";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}