using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=([^\?\&\=]+=)([^\&\=]+))(\&\1)";
string substitution = @"~";
string input = @"?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}