use strict;
my $str = '?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits';
my $regex = qr/(?<=([^\?\&\=]+=)([^\&\=]+))(\&\1)/p;
my $subst = '~';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";