$re = '/(?<=([^\?\&\=]+=)([^\&\=]+))(\&\1)/';
$str = '?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits';
$subst = "~";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;