import Foundation
let pattern = #"(?<=([^\?\&\=]+=)([^\&\=]+))(\&\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"~"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)