const regex = /(?<=([^\?\&\=]+=)([^\&\=]+))(\&\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=([^\\?\\&\\=]+=)([^\\&\\=]+))(\\&\\1)', 'g')
const str = `?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits`;
const subst = `~`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);