#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=<[id]val>-?[0-9]{12,19})\.(?=[0-9]{0,19}</[id]val>)"
Local $sString = "abc<ival>626401759728275676.</ival>xyz" & @CRLF & _
"" & @CRLF & _
"abc <dval>5019941985400004.214929968307191</dval>xyz" & @CRLF & _
"" & @CRLF & _
"abc<ival>39207738993241.</dval> xyz " & @CRLF & _
"" & @CRLF & _
"<dval>5019941985400004.214929968307191</dval>" & @CRLF & _
"" & @CRLF & _
"<ival>-6709946092725519.</dval>" & @CRLF & _
"" & @CRLF & _
"<ival>-645836507493.2494751272527455</ival>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")