import Foundation
let pattern = #"(?<=<[id]val>-?[0-9]{12,19})\.(?=[0-9]{0,19}</[id]val>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc<ival>626401759728275676.</ival>xyz
abc <dval>5019941985400004.214929968307191</dval>xyz
abc<ival>39207738993241.</dval> xyz
<dval>5019941985400004.214929968307191</dval>
<ival>-6709946092725519.</dval>
<ival>-645836507493.2494751272527455</ival>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)