use strict;
my $str = 'abc<ival>626401759728275676.</ival>xyz
abc <dval>5019941985400004.214929968307191</dval>xyz
abc<ival>39207738993241.</dval> xyz
<dval>5019941985400004.214929968307191</dval>
<ival>-6709946092725519.</dval>
<ival>-645836507493.2494751272527455</ival>';
my $regex = qr/(?<=<[id]val>-?[0-9]{12,19})\.(?=[0-9]{0,19}</[id]val>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}