re = /(?<=<[id]val>-?[0-9]{12,19})\.(?=[0-9]{0,19}<\/[id]val>)/m
str = 'abc<ival>626401759728275676.</ival>xyz
abc <dval>5019941985400004.214929968307191</dval>xyz
abc<ival>39207738993241.</dval> xyz
<dval>5019941985400004.214929968307191</dval>
<ival>-6709946092725519.</dval>
<ival>-645836507493.2494751272527455</ival>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end