const regex = new RegExp('(?<=<[id]val>-?[0-9]{12,19})\\.(?=[0-9]{0,19}</[id]val>)', 'gm')
const str = `abc<ival>626401759728275676.</ival>xyz
abc <dval>5019941985400004.214929968307191</dval>xyz
abc<ival>39207738993241.</dval> xyz
<dval>5019941985400004.214929968307191</dval>
<ival>-6709946092725519.</dval>
<ival>-645836507493.2494751272527455</ival>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}