import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<[id]val>-?[0-9]{12,19})\\.(?=[0-9]{0,19}</[id]val>)";
final String string = "abc<ival>626401759728275676.</ival>xyz\n\n"
+ "abc <dval>5019941985400004.214929968307191</dval>xyz\n\n"
+ "abc<ival>39207738993241.</dval> xyz \n\n"
+ "<dval>5019941985400004.214929968307191</dval>\n\n"
+ "<ival>-6709946092725519.</dval>\n\n"
+ "<ival>-645836507493.2494751272527455</ival>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}