# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<[id]val>-?[0-9]{12,19})\.(?=[0-9]{0,19}</[id]val>)"
test_str = ("abc<ival>626401759728275676.</ival>xyz\n\n"
"abc <dval>5019941985400004.214929968307191</dval>xyz\n\n"
"abc<ival>39207738993241.</dval> xyz \n\n"
"<dval>5019941985400004.214929968307191</dval>\n\n"
"<ival>-6709946092725519.</dval>\n\n"
"<ival>-645836507493.2494751272527455</ival>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.