#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?(?:([-+]?[0-9]*\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)"
Local $sString = ".&." & @CRLF & _
"0.0119885482338&.&." & @CRLF & _
".&2.25880593895" & @CRLF & _
".&.&.&.&.&.&.&." & @CRLF & _
".&0.295142083575&." & @CRLF & _
"0.708323350364" & @CRLF & _
".&.&0.193766679861" & @CRLF & _
".&.&.&.&7.65239874523E-4&.&."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)