use strict;
my $str = '.&.
0.0119885482338&.&.
.&2.25880593895
.&.&.&.&.&.&.&.
.&0.295142083575&.
0.708323350364
.&.&0.193766679861
.&.&.&.&7.65239874523E-4&.&.';
my $regex = qr/^.*?(?:([-+]?[0-9]*\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";