package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?:([-+]?[0-9]*\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)`)
var str = `.&.
0.0119885482338&.&.
.&2.25880593895
.&.&.&.&.&.&.&.
.&0.295142083575&.
0.708323350364
.&.&0.193766679861
.&.&.&.&7.65239874523E-4&.&.`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}