const regex = /^.*?(?:([-+]?[0-9]*\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(?:([-+]?[0-9]*\\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)', 'gm')
const str = `.&.
0.0119885482338&.&.
.&2.25880593895
.&.&.&.&.&.&.&.
.&0.295142083575&.
0.708323350364
.&.&0.193766679861
.&.&.&.&7.65239874523E-4&.&.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);