# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?(?:([-+]?[0-9]*\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)"
test_str = (".&.\n"
"0.0119885482338&.&.\n"
".&2.25880593895\n"
".&.&.&.&.&.&.&.\n"
".&0.295142083575&.\n"
"0.708323350364\n"
".&.&0.193766679861\n"
".&.&.&.&7.65239874523E-4&.&.")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.