import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?:([-+]?[0-9]*\\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)";
final String string = ".&.\n"
+ "0.0119885482338&.&.\n"
+ ".&2.25880593895\n"
+ ".&.&.&.&.&.&.&.\n"
+ ".&0.295142083575&.\n"
+ "0.708323350364\n"
+ ".&.&0.193766679861\n"
+ ".&.&.&.&7.65239874523E-4&.&.";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}