$re = '/^.*?(?:([-+]?[0-9]*\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)/m';
$str = '.&.
0.0119885482338&.&.
.&2.25880593895
.&.&.&.&.&.&.&.
.&0.295142083575&.
0.708323350364
.&.&0.193766679861
.&.&.&.&7.65239874523E-4&.&.';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;