using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+).*?class=""wp-caption-text"".*?>[\s\S]*?<\/\1>";
string input = @"<p class=""wp-caption-text""><span>android m marshmallow</span></p>
<html>
<body>
<img src=""a6marshmallow.jpg""/>
<p class=""wp-caption-text""><span>android m marshmallow</span></p>
<div class=""wp-caption-text""><p>a more complex example :oooooo</p></div>
</body>
</html>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}