const regex = /<(\w+).*?class="wp-caption-text".*?>[\s\S]*?<\/\1>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+).*?class="wp-caption-text".*?>[\\s\\S]*?<\\\/\\1>', 'g')
const str = `<p class="wp-caption-text"><span>android m marshmallow</span></p>
<html>
<body>
<img src="a6marshmallow.jpg"/>
<p class="wp-caption-text"><span>android m marshmallow</span></p>
<div class="wp-caption-text"><p>a more complex example :oooooo</p></div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}