import re
regex = re.compile(r"<(\w+).*?class=\"wp-caption-text\".*?>[\s\S]*?<\/\1>")
test_str = ("<p class=\"wp-caption-text\"><span>android m marshmallow</span></p>\n\n"
"<html>\n"
" <body>\n"
" <img src=\"a6marshmallow.jpg\"/>\n"
" <p class=\"wp-caption-text\"><span>android m marshmallow</span></p>\n"
" <div class=\"wp-caption-text\"><p>a more complex example :oooooo</p></div>\n"
" </body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")