$re = '/<(\w+).*?class="wp-caption-text".*?>[\s\S]*?<\/\1>/';
$str = '<p class="wp-caption-text"><span>android m marshmallow</span></p>
<html>
<body>
<img src="a6marshmallow.jpg"/>
<p class="wp-caption-text"><span>android m marshmallow</span></p>
<div class="wp-caption-text"><p>a more complex example :oooooo</p></div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);