import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w+).*?class=\"wp-caption-text\".*?>[\\s\\S]*?<\\/\\1>";
final String string = "<p class=\"wp-caption-text\"><span>android m marshmallow</span></p>\n\n"
+ "<html>\n"
+ " <body>\n"
+ " <img src=\"a6marshmallow.jpg\"/>\n"
+ " <p class=\"wp-caption-text\"><span>android m marshmallow</span></p>\n"
+ " <div class=\"wp-caption-text\"><p>a more complex example :oooooo</p></div>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}