# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({{i18n .*?}})/$/g;t' <<< "<input class=\"scf-composer-msg\" type=\"text\" class=\"scf-js-userfilter\" data-field-type=\"userdropdown\" name=\"composedFor\" placeholder=\"{{#if properties.composedFor}}{{i18n \"Composed for \"}}
{{author.name}}{{else}}{{i18n \"Compose On Behalf of a User\"}}{{/if}}\" data-attrib=\"composedFor\" /> "