// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"({{i18n .*?}})").unwrap();
let string = "<input class=\"scf-composer-msg\" type=\"text\" class=\"scf-js-userfilter\" data-field-type=\"userdropdown\" name=\"composedFor\" placeholder=\"{{#if properties.composedFor}}{{i18n \"Composed for \"}}
{{author.name}}{{else}}{{i18n \"Compose On Behalf of a User\"}}{{/if}}\" data-attrib=\"composedFor\" /> ";
let substitution = "$";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}