re = /({{i18n .*?}})/
str = '<input class="scf-composer-msg" type="text" class="scf-js-userfilter" data-field-type="userdropdown" name="composedFor" placeholder="{{#if properties.composedFor}}{{i18n "Composed for "}}
{{author.name}}{{else}}{{i18n "Compose On Behalf of a User"}}{{/if}}" data-attrib="composedFor" /> '
subst = '$'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result