import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{\\{i18n .*?\\}\\})";
final String string = "<input class=\"scf-composer-msg\" type=\"text\" class=\"scf-js-userfilter\" data-field-type=\"userdropdown\" name=\"composedFor\" placeholder=\"{{#if properties.composedFor}}{{i18n \"Composed for \"}}\n"
+ "{{author.name}}{{else}}{{i18n \"Compose On Behalf of a User\"}}{{/if}}\" data-attrib=\"composedFor\" /> ";
final String subst = "$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}