import Foundation
let pattern = #"({{i18n .*?}})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<input class="scf-composer-msg" type="text" class="scf-js-userfilter" data-field-type="userdropdown" name="composedFor" placeholder="{{#if properties.composedFor}}{{i18n "Composed for "}}
{{author.name}}{{else}}{{i18n "Compose On Behalf of a User"}}{{/if}}" data-attrib="composedFor" />
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)