# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({{i18n .*?}})"
test_str = ("<input class=\"scf-composer-msg\" type=\"text\" class=\"scf-js-userfilter\" data-field-type=\"userdropdown\" name=\"composedFor\" placeholder=\"{{#if properties.composedFor}}{{i18n \"Composed for \"}}\n"
"{{author.name}}{{else}}{{i18n \"Compose On Behalf of a User\"}}{{/if}}\" data-attrib=\"composedFor\" /> ")
subst = "$"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.