const regex = /({{i18n .*?}})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({{i18n .*?}})', 'g')
const str = `<input class="scf-composer-msg" type="text" class="scf-js-userfilter" data-field-type="userdropdown" name="composedFor" placeholder="{{#if properties.composedFor}}{{i18n "Composed for "}}
{{author.name}}{{else}}{{i18n "Compose On Behalf of a User"}}{{/if}}" data-attrib="composedFor" /> `;
const subst = `$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);