using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";\s+";
string substitution = @";";
string input = @"Lidar; Wind field; Temperature; Aerosol; Fabry-Perot etalon
Compressive ghost imaging; Guided filter; Single-pixel imaging";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}