import Foundation
let pattern = #";\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Lidar; Wind field; Temperature; Aerosol; Fabry-Perot etalon
Compressive ghost imaging; Guided filter; Single-pixel imaging
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)