use strict;
my $str = 'Lidar; Wind field; Temperature; Aerosol; Fabry-Perot etalon
Compressive ghost imaging; Guided filter; Single-pixel imaging';
my $regex = qr/;\s+/p;
my $subst = ';';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";