#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[1-9][0-9]*[Xx]\b"
Local $sString = "Should return true:" & @CRLF & _
"" & @CRLF & _
"2x" & @CRLF & _
"31x" & @CRLF & _
"3x abcd" & @CRLF & _
"1x" & @CRLF & _
"100x" & @CRLF & _
"" & @CRLF & _
"Should return false:" & @CRLF & _
"" & @CRLF & _
"2x3" & @CRLF & _
"" & @CRLF & _
"3xabc" & @CRLF & _
"" & @CRLF & _
"asdf3x" & @CRLF & _
"" & @CRLF & _
"0x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")