use strict;
my $str = 'Should return true:
2x
31x
3x abcd
1x
100x
Should return false:
2x3
3xabc
asdf3x
0x';
my $regex = qr/\b[1-9][0-9]*[Xx]\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}