import re
regex = re.compile(r"\b[1-9][0-9]*[Xx]\b", flags=re.MULTILINE)
test_str = ("Should return true:\n\n"
"2x\n"
"31x\n"
"3x abcd\n"
"1x\n"
"100x\n\n"
"Should return false:\n\n"
"2x3\n\n"
"3xabc\n\n"
"asdf3x\n\n"
"0x")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")