re = /\b[1-9][0-9]*[Xx]\b/m
str = 'Should return true:
2x
31x
3x abcd
1x
100x
Should return false:
2x3
3xabc
asdf3x
0x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end