package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[1-9][0-9]*[Xx]\b`)
var str = `Should return true:
2x
31x
3x abcd
1x
100x
Should return false:
2x3
3xabc
asdf3x
0x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}