// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[1-9][0-9]*[Xx]\b").unwrap();
let string = "Should return true:
2x
31x
3x abcd
1x
100x
Should return false:
2x3
3xabc
asdf3x
0x";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}