# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([+-]?(?:(?:\d+x\^\d+)|(?:\d+x)|(?:\d+)|(?:x)))//g;t' <<< "2x^3+4x^2+5x-42
2x+x+1"