const regex = /([+-]?(?:(?:\d+x\^\d+)|(?:\d+x)|(?:\d+)|(?:x)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+-]?(?:(?:\\d+x\\^\\d+)|(?:\\d+x)|(?:\\d+)|(?:x)))', 'g')
const str = `2x^3+4x^2+5x-42
2x+x+1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);