using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?(?:(?:\d+x\^\d+)|(?:\d+x)|(?:\d+)|(?:x)))";
string substitution = @"";
string input = @"2x^3+4x^2+5x-42
2x+x+1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}