re = /([+-]?(?:(?:\d+x\^\d+)|(?:\d+x)|(?:\d+)|(?:x)))/
str = '2x^3+4x^2+5x-42
2x+x+1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result