# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-zA-Z',.?!\s]//g;t' <<< "i'm so happy that you're here with me! :)"